Releases

Back CVE-2022-28978 Stored XSS with user name in site membership

Description

Stored cross-site scripting (XSS) vulnerability in the Site module's user membership administration page in Liferay Portal 7.0.1 through 7.4.1 allows remote attackers to inject arbitrary web script or HTML via a user's name.

Severity

null (null)

Notes

Liferay Portal 7.4: There is no patch available for Liferay Portal 7.4. Instead, users should upgrade to Liferay Portal 7.4 GA3 (7.4.2)

Liferay Portal 7.3: Source patch for Liferay Portal 7.3.7 GA8 (7.3.7) is available on GitHub. Details for working with source patches can be found on the Patching Liferay Portal page.

Liferay Portal 7.0, 7.1 and 7.2: There is no patch available for Liferay Portal 7.2.1 and earlier. Instead, users should upgrade to Liferay Portal 7.3.7 and apply the latest patch for Liferay Portal 7.3

Publication date: Mon, 24 Jan 2022 16:00:00 +0000

The security advisories on this page is for Liferay's open source projects (e.g., Liferay Portal). Security advisories for Liferay's enterprise offerings (e.g., Liferay DXP) are available in Help Center.