Releases

Back CVE-2022-26594 XSS vulnerability with form field help text

Description

Multiple cross-site scripting (XSS) vulnerabilities in Liferay Portal 7.3.5 through 7.4.0 allow remote attackers to inject arbitrary web script or HTML via a form field's help text to (1) Forms module's form builder, or (2) App Builder module's object from view's form builder.

Severity

null (null)

Notes

Liferay Portal 7.4: There is no patch available for Liferay Portal 7.4.0. Instead, users should upgrade to Liferay Portal 7.4 GA2 (7.4.1)

Liferay Portal 7.3: Source patch for Liferay Portal 7.3.7 GA8 (7.3.7) is available on GitHub. Details for working with source patches can be found on the Patching Liferay Portal page.

Acknowledgments

Duy Huynh

Publication date: Mon, 24 Jan 2022 16:00:00 +0000

The security advisories on this page is for Liferay's open source projects (e.g., Liferay Portal). Security advisories for Liferay's enterprise offerings (e.g., Liferay DXP) are available in Help Center.