Blogs

Blogs

Liferay Portal 7.4 GA40 and Liferay Commerce 4.0 GA40 Release

We are pleased to announce the release of Liferay Portal 7.4 GA40 and Liferay Commerce 4.0 GA40!

Download options

Liferay Portal and Liferay Commerce share the same Bundle and Docker image.  To get started using either Liferay Portal or Liferay Commerce, choose the best download option suited for your environment below.

Docker image

To use Liferay Portal 7.4 GA40:

docker run -it -p 8080:8080 liferay/portal:7.4.3.40-ga40

For more information on using the official Liferay docker image see the liferay/portal repo on Docker Hub.

Bundles and other download options

If you are used to binary releases, you can find the Liferay Portal 7.4 GA40 and Liferay Commerce 4.0 GA40 release on the download page.  If you need additional files (for example, the source code, or dependency libraries), visit the release page.

Dependency Management

For development using the Liferay Platform, update Liferay Workspace to use the  latest dependencies, by adding the following line to the build.gradle file:

dependencies {
	compileOnly group: "com.liferay.portal", name: "release.portal.api"
}

All portal dependencies are now defined with a single declaration. When using an IDE such as Eclipse or IntelliJ all apis are immediately available in autocomplete for immediate use.  

By setting a product info key property it will be possible to update all dependencies to a new version by updating the liferay.workspace.product property in the liferay workspace projects gradle.property file:

liferay.workspace.product = portal-7.4-ga40

When using an IDE such as Eclipse or IntelliJ all apis are immediately available in autocomplete for immediate use.

Features

Core Upgrades

Simplified the upgrade development by improving the API

  • No need to use the hasColumn* methods prior to alter a table with the alterTable* methods. Now all the checks are done inside the alter methods.

  • New UpradeProcessFactory class with static methods that generate inline upgrade processes for the most common database operations (add column, drop column, alter column name and alter column type).

  • New methods getPreUpgradeSteps and getPostUpgradeSteps in the UpgradeProcess class to allow  better control over complex upgrades and simplify writing of upgrade processes.

https://issues.liferay.com/browse/LPS-149180

Documentation

All documentation for Liferay Portal and Liferay Commerce can now be found on our documentation site: learn.liferay.com.  For more information on upgrading to Liferay Portal 7.4 GA40 see refer to the Upgrade Overview.

Compatibility Matrix

Liferay's general policy is to test Liferay Portal and Liferay Commerce  against newer major releases of operating systems, open source app servers, browsers, and open source databases (we regularly update the bundled upstream libraries to fix bugs or take advantage of new features in the open source we depend on). 

Liferay Portal 7.4 GA40 and Liferay Commerce 4.0 GA40 were tested extensively for use with the following Application/Database Servers: 

Application Server

  • Tomcat 9.0

  • Wildfly 18.0, 23.0

Database

  • MySQL 5.7, 8.0

  • MariaDB 10.2, 10.4

  • PostgreSQL 12.x, 13.x

JDK

  • IBM J9 JDK 8

  • Oracle JDK 8

  • Oracle JDK 11

  • All Java Technical Compatibility Kit (TCK) compliant builds of Java 11 and Java 8

Search Engine Compatibility Matrix

Source Code

Source is available as a zip archive on the release page, or on its home on GitHub. If you're interested in contributing, take a look at our contribution page.

Bug Reporting

If you believe you have encountered a bug in the new release you can report your issue by following the bug reporting instructions.

Getting Support

Support is provided by our awesome community. Please visit helping a developer page for more details on how you can receive support.

Fixes and Known Issues

Blogs

Hello,

Great news all those release every fridays.

But one question, is PostgreSQL 14.x is supported too ? I see it on the compatibily matrix but not here.

 

Eric.

Hi Eric, PostgreSQL 14.x is supported on Portal 7.4 as well.  I missed that a couple of requirements had changed.  I will make sure that the next release is up to date.  Thanks for the heads up!

-Jamie