Blogs

Blogs

Clay React Components Issue

A really quick post to share something important with you React + Clay developers out there...

A recent update to Clay had a breaking internal change.

If after deploying your React portlet and you try to place it on the page and you get errors in the JS console like:

liferay-amd-loader | Errors returned from server for require( ["my-module@1.0.0"] ):
 "Missing dependency '@my-module$clayui/provider' of 
   '@my-module$clayui/shared@3.32.0/lib/Portal'"
 "Missing version constraints for '@my-module$clayui/provider' in 
   package.json of '@my-module$clayui/shared@3.32.0' 
     (required from its 'lib/Portal' module)"

this means that you're using a version since the breaking change was introduced.

It's really easy to solve, though. Just npm install @clayui/provider or yarn add @clayui/provider and then build and deploy your module again.

If after doing this you still get the same error, try deleting the build and dist folders and do a clean build and that should take care of it.

Good Luck!